Leaving out noteoff bugs Alex-version

R
Rien Heuver posted Dec 30, 15:59:

I use Alex's version of samplerbox from http://samplerbox.readthedocs.io.

So I have a simple script to test the samplerbox without using a midi-device. The script can be found here:
https://gitlab.com/rienheuver/electrophone/blob/master/midi_tester.py
The problem is that when I play a note, it will then also play another note a few pitches higher and another etc. until it ends in a high pitch noise. If I add a noteoff, it will fix the problem. However, I don't want noteoffs because I'm building a percussion midi-instrument. My definitions file looks like this:
%%mode=Once
%notename.wav

I have been debugging in the code and can't find it yet. The midi-note is only received once by SamplerBox. Any clue what's going on here? I'd love to be able to fix this.

R
Roel van de Laar posted Dec 30, 17:24:

Hi Rien,

I think I'm struggling with the same problem and the solution seems in this post:

http://www.samplerbox.org/forum/46

But I'm not sure how to do it, maybe you?!.
When I play my samplerbox from an USB keyboard it's all good,uhh,.. OK I got some hanging notes quite often... But when I play it from my midisequencer it doesn't work, only some notes once in a while.
My midisequencer doesn't send noteoffs, only noteon's with a velocity of 0.
That shouldn't be a problem cause it's the midi standard and I never had this problem before with my sequencer. But I guess it's the problem now, any help would be appreciated.

R
Rien Heuver posted Jan 2, 16:56:

Ok, I was able to fix the problem simply by not being a stupid as before (and tracing my stupidity). My definitions file was called definitions.txt instead of definition.txt
It now works beautifully :P.
@Roel, thanks for the reply, but I'm not using serial midi, so my problem wasn't related.

...

  (not published)
  I want to post as guest
 

Post