what kind of latency are you folks getting?

E
em-crab posted Jun 29, 16:31:

i'm using a raspberry pi 2 model B and the latency is pretty bad, i haven't measured it yet but it's not really usable for anything other than soft attack sounds like the flute.

i tried using the circuit to build my own midi input to see if that was faster than my yamaha midi-usb cable to which i connected REAPER to the raspberry pi, but either something is wrong with my circuit or something's off with the schematic here http://www.samplerbox.org/files/samplerbox_schematics.jpg

H
HansEhv posted Jul 1, 02:02:

It's quite good actually.
I also have pi2 model B and attach a midi keyboard directly to a USB port as well as a drumpad using a Roland usb to midi cable to connect it to another USB port.
I have also used e cheap chinese interface, which worked ok too until - being cheap crap - it starting draining power
Especially with the drum pad I certainly would have noticed bad latency.
I did not build the direct midi input.

E
em-crab posted Jul 5, 18:38:

any tips on improving the latency? i'm running reaper at block size 256 and it's a good bit less latent than the samplerbox.

A
AlexM posted Jul 6, 07:13:

One thing you could try is adding latency="low" to the parameters on this line:

https://github.com/josephernest/SamplerBox/blob/master/samplerbox.py#L354

(by default it's set to "high")

So instead it will read:

sd = sounddevice.OutputStream(device=AUDIO_DEVICE_ID, blocksize=512, samplerate=44100, channels=2, dtype='int16', callback=AudioCallback latency="low")

Z
zoompig posted Jul 9, 06:09:

I just tried the latency="low" parameter on my pi2-B, as suggested by AlexM. It managed to drop my latency to about 20ms, which becomes usable. It was hovering around 50ms. I'm using a PCM5122 based DAC. If I also change to blocksize=256, the latency drops to about 10ms or so. Nice. I'm running Jessie with Kernel 4.9.24
Thanks for the suggestions!

R
redtide posted Aug 21, 22:50:
...

  (not published)
  I want to post as guest
 

Post