starting first time after boot is different from starting subsequently

U
Uli posted Sep 21, 21:17:

Hello Joseph, hello folks,

first of all Joseph thank you for your work, I love the combination of my raspi, a powerbank and a small midi keyboard. Great!

I want to report a strange effect that I was hoping to get rid of after the release of the raspiv3 img, but it is still there:

on both the manual install (jessie raspbian with samplerbox from github) and the new Raspi3 image versions, samplerbox is not working correctly if started the first time after booting or rebooting. Notes are playing for a very long time (multiple seconds) on the manual install version, and they play forever on the new V3 image version. After stopping and restarting samplerbox.py, everything works fine from then on until the next reboot.

One observation: when connecting the midi keyboard after the system startup, it works fine, the problem only shows up when the keyboard is connected upon startup. However, the latter is the preferred setup since I prefer to have everything in place and then boot up.

Since I only have one MIDI keyboard, I can not test with different devices. As a workaround I changed the startup script so that it starts up samplerbox, then waits for 10 seconds, kills it, and then restarts it, but maybe someone has an idea what is going on.

Best Regards
Uli from Cologne, Germany

A
Andy posted Sep 22, 13:21:

Hi Uli,

I've had similar problems with keyboard connection before system startup. Like you, I need to plug the keyboard into RPi after startup for the system to work. It's a bit odd, since I can see that the keyboard is being detected during the Linux boot.

-Andy

U
Uli posted Sep 26, 18:46:

Same here, I see it detected correctly and then it does not work. Also, if I boot with the keyboard attached and then unplug it, i get tons of USB error messages and eventually a kernel panic.
I would suspect that it is a problem with our midi devices, since the problem is not widely reported. I have a Garagekey 37-key-keyboard, which is detected as "Tatong ... blahblah...."

...

  (not published)
  I want to post as guest
 

Post